All com.android.support libraries must use the exact same version specification

For example:
If You using
compileSdkVersion 25
buildToolsVersion "25.0.0"

You have to using latest version of support libraries with number 25.
Also check the library project!

 
apply plugin: 'com.android.application'
 
android {
    compileSdkVersion 25
    buildToolsVersion "25.0.0"
 
    defaultConfig {
        applicationId "cz.okhelp.prislovi_cz_test"
        minSdkVersion 13
        targetSdkVersion 25
    }
 
    buildTypes {
        release {
            minifyEnabled true
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-project.txt'
 
        }
    }
}
 
dependencies {
    compile fileTree(include: ['*.jar'], dir: 'libs')
    androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', {
        exclude group: 'com.android.support', module: 'support-annotations'
    })
    testCompile 'junit:junit:4.12'
    compile project(':library_studio')
 
    /*  ERROR message: You have to update 
     compile 'com.android.support:appcompat-v7:23.4.0'
     compile 'com.android.support:design:23.4.0'
    */
 
    compile 'com.android.support:support-v4:25.1.0'
    compile 'com.android.support:appcompat-v7:25.1.0'
    compile 'com.android.support:design:25.1.0'
}

Update in module build.gradle file
or
select from menu File -> Project Structure and set up correct libraries.

This entry was posted in Android Studio, Bugs, warnings, errors and tagged , . Bookmark the permalink.


Comments are closed.

2,938 views